Training resources and Help information

Is there a user manual?

Yes, you can download the Introduction to iStudio Publisher (PDF), which is included in the installation disk image file.

This user manual was produced using iStudio Publisher.

Are there any video tutorials?

Yes, here are a range of video tutorials on our website.

Does iStudio Publisher include Help information?

Yes, iStudio Publisher includes comprehensive Help pages and context relevant Help, which you can access by clicking on the ‘?’ buttons that appear on many of the windows and dialogs.

We recommend that every new user reads the Rapid Start Guide, which you can open from the Help menu. Further to this, a “getting started” pathway is signposted through some of the other Help pages, which is particularly designed to help users who are new to desktop publishing (DTP).

There’s also an online copy of all the Help pages.

Installing, licensing and buying – both editions

What operating systems does iStudio Publisher support?
App Store Edition

The App Store Edition of iStudio Publisher runs on all Macs with Mac OS X 10.6.6 (Snow Leopard) or later.

Website Download Edition

The Website Download Edition of iStudio Publisher runs on all Macs with Mac OS X 10.4.x (Tiger) or later.

Are iStudio Publisher updates free of charge?

Yes, our update policy is to provide all (1.x) minor releases and all (1.x.y) maintenance releases free of charge. We recommend you install all new iStudio Publisher updates as they become available.

How do I install updates?
App Store Edition

The App Store Edition of iStudio Publisher includes the standard App Store update mechanism.

Website Download Edition

Whenever you start up the Website Download Edition of iStudio Publisher you will automatically be offered any new update we’ve released. You simply need to accept an update to install it.

How do the App Store Edition and Website Download Edition differ?

iStudio Publisher is available as an App Store Edition and a Website Download Edition. These are functionally identical apart from the following differences:

  • The Website Download Edition incorporates our own licensing system and has a Licensing sub-menu under the Help menu. The App Store Edition has no Licensing sub-menu and incorporates Apple’s digital rights management system, which requires you to have an Apple ID and an iTunes account.
  • The Website Download Edition can be run as a 30-day trial, or licensed by purchasing a license activation code. The App Store Edition is not available as a trial (but will install over the Website Download Edition being run as a trial).
  • The Website Download Edition will run on Mac OS X 10.4.x (Tiger) or later, whereas the App Store Edition requires Mac OS X 10.6.6 (Snow Leopard) or later, which was the first version to include the App Store.
  • You’ll get updates for the App Store Edition later, due to the App Store review time.

Moving forwards we expect to release free updates for both the Website Download and App Store Editions of iStudio Publisher and keep them functionally identical. Neither is regarded as a lesser product.

Installing, licensing and buying – Website Download Edition

Can I try before I buy?

IMPORTANT: This FAQ only applies to the Website Download Edition of iStudio Publisher and not the App Store Edition.

Yes, everyone can download iStudio Publisher and try it FREE for 30 days (full functionality trial).

The installation software is available from our downloads page.

There are short video tutorials showing how to download and install iStudio Publisher, and install your 30-day trial license.

If I buy iStudio Publisher, what do I get?

IMPORTANT: This FAQ only applies to the Website Download Edition of iStudio Publisher and not the App Store Edition.

You will receive an email containing your License Activation Code(s) and purchase receipt. There will be a separate License Activation Code for each license you buy. Each License Activation Code can be used to license iStudio Publisher on one Mac.

Do you offer discounts?

IMPORTANT: This FAQ only applies to the Website Download Edition of iStudio Publisher and not the App Store Edition.

Yes, we offer Educational Discount (40% Off) and Volume Discounts – click here for more information.

Do you offer license multi-packs?

IMPORTANT: This FAQ only applies to the Website Download Edition of iStudio Publisher and not the App Store Edition.

Yes, we offer a Personal 2-Pack License, Family 3-Pack License and Single Computer License 5-Pack – click here for more information.

Why hasn’t my purchase receipt email arrived?

IMPORTANT: This FAQ only applies to the Website Download Edition of iStudio Publisher and not the App Store Edition.

After placing your order, you will receive an email from SWREG containing your purchase receipt and License Activation Code(s). This email will normally arrive within a few minutes of completing your payment. If you do not receive it within 24 hours (credit card purchases only) please check if it’s caught in your spam filter, or otherwise contact us.

How do I install my licensed copy of iStudio Publisher?

IMPORTANT: This FAQ only applies to the Website Download Edition of iStudio Publisher and not the App Store Edition.

A licensed copy of iStudio Publisher is based on the same software as a trial copy. To get licensed, simply enter a License Activation Code when the application asks for it. Each License Activation Code is 20 characters long. It’s easiest to copy and paste a License Activation Code directly from your purchase receipt email.

You can either license an existing trial copy of iStudio Publisher or a new installation. The installation software is available from our downloads page. There are short video tutorials showing how to download and install iStudio Publisher, and install your full license.

Why must I log in as an administrator to be able to register?

IMPORTANT: This FAQ only applies to the Website Download Edition of iStudio Publisher and not the App Store Edition.

If you are logged into your Mac as a Standard Account holder (as opposed to an Administrator Account holder), you will be asked to log in as an Admin when you register. This is required because iStudio Publisher installs your license file (either a 30-day trial or a full purchased license) into a folder that requires Admin write permission, which is for two reasons:

  1. To make the license available to all users on your Mac (it would be insufficient to store the license file in your Standard Account folder, which would render it inaccessible to other Standard Account holders).
  2. To prevent other Standard or Guest Account users from being able to delete the license (for malicious purposes).

You can display a list of all account names on your Mac by opening the System Preferences window and clicking Accounts. It says either Admin or Standard below each name, enabling you to find an Admin account name to use.

NOTE: The Administrator Login Dialog is a standard Mac OS X dialog that’s displayed in response to iStudio Publisher requesting write permission to folder space that has Admin ownership. Mac OS X only returns control to iStudio Publisher when this dialog is dismissed. Importantly, iStudio Publisher doesn’t get involved with processing this dialog and never sees your password. iStudio Publisher simply gets notified of whether the license file installation can proceed (or not), which depends on whether the Admin login was completed successfully.

Can I transfer my iStudio Publisher license to a different Mac?

IMPORTANT: This FAQ only applies to the Website Download Edition of iStudio Publisher and not the App Store Edition.

Yes, you can transfer a license by completing the following two steps:

  1. Deactivate the license on your old Mac (by choosing menu option Help > Licensing > Unlicense). You will be reminded of your License Activation Code and so won’t need to find your original purchase receipt email.
  2. License your new Mac as normal.

If you are unable to deactivate the license on your old Mac, for example, if the hard drive has crashed, please proceed as follows:

  1. Contact us for a license reset. To help us identify you, please tell us your License Activation Code or the email address you used to make your purchase.
  2. We will email you to confirm your license has been reset.
  3. Run iStudio Publisher.
  4. Choose menu option Help > Licensing > License, and install you license. There are short video tutorials showing how to download and install iStudio Publisher, and install your full license.

About iStudio Publisher documents

Can I set custom paper sizes and large paper sizes?

Yes, standard and custom paper sizes can be set up from the Page Setup dialog, which is available from the New Document dialog, the File menu, or the Page button in the Document Inspector.

On the Page Setup dialog, set the Format For drop-down to Any Printer if you are preparing a PDF file for printing on a printer that is not configured on your system.

Even with the Format For drop-down set to Any Printer, some standard paper sizes (for example, A2, A1 and A0) may not be available on the Paper Size drop-down. To use these unavailable sizes, you will need to set them as a custom paper size.

When entering a custom paper size it’s usual to enter the smaller dimension as the Width and the larger dimension as the Height. You can then change the page orientation from portrait to landscape via the Orientation control on the Page Setup dialog, as required.

For more information about the Page Setup dialog please see the iStudio Publisher Help pages, and in particular click the Page Setup dialog link at the bottom of the Creating a New Document page, which links through to the standard Mac OS X Help pages on this subject.

Does iStudio Publisher support spread editing across facing pages?

Yes, you can create a document in spread editing mode – simply select the Spread Editing checkbox on the New Document dialog. Spread editing enables you to view and lay out document content across facing pages, which is commonly used for creating magazines and brochures.

NOTE: You need to create your document in spread editing mode as you can’t switch into it later.

What is the maximum number of pages in an iStudio Publisher document?

This was increased to 9999 pages in iStudio Publisher Version 1.1.2.

Are iStudio Publisher .ispx files based on a proprietary format?

iStudio Publisher files are XML based, which is non-proprietary and in a format that is both human-readable and machine-readable.

Can I use Small Caps, Old Style Figures and other alternative font characters?

Yes, but you will need to use a TrueType font that has the Small Caps and Old Style Figures housed in a separate font file. These fonts work with the current version of iStudio Publisher because the Small Caps and Old Style Figures characters are mapped to the same Unicode points as the other forms of the font (regular, bold, italic, etc.).

Can I use OpenType fonts?

At present, iStudio Publisher only provides basic Roman support for OpenType fonts. In the future, we plan to add more support for OpenType fonts, but in the meantime you can choose Edit > Special Characters to select and insert Small Caps, Old Style Figures and other alternative font characters in OpenType fonts.

NOTE: This approach is slow and only realistic for small quantities of text. It can be speeded up a little by using Edit > Special Characters to create an iStudio Publisher file containing a reusable palette of alternative characters to copy and paste into your other iStudio Publisher documents.

How do I insert an image (including PDF, EPS or AI) inside a shape?

The quickest way is to drag and drop images directly from your Desktop, Finder window, or from other applications that support drag and drop. Hover your mouse over an existing shape and a visual indication will confirm that the shape is about to receive a dropped image.

Alternatively, you can use the copy and paste commands, Insert menu, or Image Inspector to add an image to one or more existing shapes – simply select the shapes with the Pointer Tool BEFORE pasting / inserting the image.

NOTE: You can drop images onto any blank page or canvas area, or paste/insert images with NO shape selected. In all of these cases, a default shape (rectangle) is created to hold each image.

Can I insert a multi-page PDF file into an iStudio Publisher document?

Yes, but only one page at a time, by following these steps:

  1. Open the PDF file in Preview, and show page thumbnails in Preview’s sidebar.
  2. In Preview’s thumbnails, navigate to a page you want to copy, click on the thumbnail and then simply drag and drop it into your iStudio Publisher document. The full sized PDF page will be copied.
  3. Repeat for other pages.

If you try to insert a multi-page PDF file into an iStudio Publisher document by choosing menu option Insert > PDF, only the first page of the PDF will be inserted.

NOTE: You can’t import and edit PDF files in iStudio Publisher, but you can insert them into documents as images, and ‘patch’ them by overlaying shapes and adding replacement shapes, text and image.

Sharing, exporting and workflow

Can others read my iStudio documents if they don’t have iStudio Publisher?

Yes, you can either print iStudio Publisher documents to paper copy or export to PDF format for sharing. PDF files can be read by all Macs and Windows machines.

NOTE: Windows users may need to install PDF reader software (for example, Adobe Reader or PDF-XChange Viewer), which are both FREE to download and use.

Can others collaborate on my iStudio documents without iStudio Publisher?

Yes, you can export and distribute your iStudio documents as PDF files. Ask others to annotate and mark up the PDF files. Finally, you can review their PDF markup and make the corresponding edits to your original iStudio documents.

For Mac users, ask them to open the PDF in Preview.app, which includes annotation and mark up tools.

For Windows users, Adobe Reader is the most common PDF reader. It contains annotation and mark up tools, but these are only available if the PDF has been enabled for commenting using Adobe Acrobat (for example, open the PDF file in Acrobat 9, choose Comments > Enable for Commenting and Analysis in Adobe Reader, and save the PDF before sending it out). If you happen to own a copy of Adobe Acrobat this will be the most convenient solution for the majority of Windows users because they are likely to have Adobe Reader already installed.

If you don’t have Adobe Acrobat, there’s another solution for Windows users that’s both excellent and FREE! – ask them to download and install PDF-XChange Viewer – it’s a PDF reader that includes comprehensive annotation and markup facilities.

Can I export iStudio Publisher documents to other file formats?

Yes, the current version of iStudio Publisher supports exporting documents to PDF file, and text flows to EPUB file (ebook format) and RTF file (styled text).

You can also export to other image formats via the standard Mac OS X print dialog and Preview, as follows:

  1. In iStudio Publisher, choose menu option File > Print.
  2. In the Print dialog box, click the PDF button and choose Open PDF in Preview.
  3. In Preview, choose menu option File > Export (or File > Save As on some versions of Mac OS X).
  4. Choose Format: JPEG, PNG or TIFF.
  5. Set the save location and filename and click the Save button to finish.
  6. If required, open the image in Preview or other image editing app and crop to size.

An alternative method is to set the Edit Mode to Preview (menu option View > Preview Mode, or click the corresponding toolbar button), adjust the document zoom factor to display your design at the exactly the required size for the image, and take a screen shot.

We plan to add a new range of image export options to a future update of iStudio Publisher.

Can I import files from other DTP or word processor applications?

No, iStudio Publisher does not include import filters for proprietary format files produced by other desktop publishing (DTP) or word processor applications such as Microsoft Publisher, Quark Xpress, Adobe InDesign, Apple Pages or Microsoft Word. These file formats are sometimes protected by patents and not documented publicly. Although we may revisit this, our current development efforts are focussed on adding other features instead.

NOTE: You can copy and paste styled text (in Rich Text Format) from other applications.

Can I reuse content from documents produced by other DTP applications?

Yes, you can copy and paste text and images from other applications into iStudio Publisher documents.

If you can’t open a source document on your Mac because you don’t have the corresponding application software installed, you can still reuse its content in your iStudio documents by arranging to receive a PDF export of the original file, and extracting its text and images using an extraction utility. File Juicer is a good example of a text and image extraction utility.

Can I produce PDF files ready for printing at a commercial print shop?

Yes, you can satisfy all of the typical requirements of a commercial print shop, including high resolution images, CMYK colors and embedded fonts. It’s worth checking with your print shop what they require.

At present, iStudio Publisher creates PDF files using Mac OS X’s inbuilt services. It provides no specific options or settings for PDF processing, but you can optionally add your own PDF processing using Mac OS X’s Quartz filters. We are considering adding support for PDF settings in the future. That’s not to say iStudio Publisher creates poor quality PDFs! In fact, we’ve made several design choices within our PDF creation process to produce PDFs suitable for high quality printing.

Digital images are embedded in iStudio Publisher document (.ispx) files in their original formats. Exporting as a PDF also embeds the original format images in the PDF file at their original resolution and compression level, ensuring there’s no loss of image quality. You do need to start off with images of adequate resolution and quality.

iStudio Publisher can be used as part of a colour-managed workflow. Document images and other coloured document artifacts (lines, fills, text, etc) are all tagged with ICC colour profiles, which are stored in iStudio Publisher document files and transferred to exported PDFs. ICC colour profiles can be changed during document editing. Some printers may require colors to be set to CMYK. For more information about setting CMYK colours, please see the iStudio Publisher Help page “CMYK colors”.

iStudio Publisher creates PDF files with font subsets embedded, which ensures all font information remains available for viewing on other computers even if they don’t have your document’s fonts installed. Embedding font subsets involves only including the individual font glyphs (characters) that are actually used in your document rather than embedding complete fonts; it helps to minimize the PDF file size. iStudio Publisher controls and sets the position of each and every character in the PDF rather than relying on the use of default PDF layout algorithms, so you can also be sure your page layout will be faithfully reproduced.

Can I design and print booklets?

Yes, you can create a multi-page booklet from several sheets of paper printed on both sides and folded in half. You can design an iStudio Publisher document for booklet printing as reader’s spreads, i.e. with the pages arranged in the same running order as they will appear to the reader in the finished printed booklet. This requires the use of page imposition software, which rearranges the page order for booklet printing, referred to as printer’s spreads.

iStudio Publisher’s booklet design supports:

  • selection of custom page/paper size
  • spreading text and images across facing pages

iStudio Publisher’s booklet printing uses Christoph Vogelbusch’s FREE Create Booklet PDF Service (Many Thanks Christoph!), which you will need to download and install before you can print booklets. Download the Create Booklet PDF Service and follow the installation instructions included with the installation dmg.

Download booklet printing instructions. These are presented in an iStudio Publisher document that has also been designed for printing out as an example booklet (A5 and Half US Letter page size versions included).

Can I reduce the size of PDF files exported by iStudio Publisher?

Yes, you can reduce the size of PDF files exported by iStudio Publisher by using a collection of FREE PDF filters written by Jerome Colas. (Many Thanks Jerome!)

IMPORTANT: These filters are designed to reduce PDF file size by compressing the images included within a PDF. If your document is all text or only includes low resolution images, the filters will not help and may actually result in a larger file size than would otherwise be created without them.

To install the filters:

  1. Download the reduce PDF file size filters.
  2. If your computer is running Mac OS X 10.7 Lion or later, you may need to complete the following steps a. to c. to make the Library folder visible in Finder:
    1. Navigate to the Utilities folder, which is located in the Applications folder.
    2. Open the Terminal application.
    3. Enter (or copy and paste) the following command into the terminal window and then press the Return key to execute it:
      chflags nohidden /Library
  3. Unzip the filters.
  4. On Mac OS X 10.7 Lion or later, copy the filters to this folder:
    Macintosh HD/Library/PDF Services
    On Mac OS X 10.6 Snow Leopard or earlier, copy the filters to this folder:
    Macintosh HD/Library/Filters

Here’s a screen shot of Finder showing the filters in the /Library/PDF Services folder:
PDF filters copied into the /Library/PDF Services/ folder

To use the filters:

To export a reduced size PDF file, simply follow these steps:

  1. In iStudio Publisher (or any other app), choose menu option File > Print.
  2. On the print dialog box, click the PDF drop-down button (it’s in the bottom left corner).
  3. Choose one of the reduce PDF file size filters by clicking it. It’s best to choose 300 dpi or more for documents that are going to be printed out, but fine to choose a lower resolution if the PDF will only be viewed on a monitor.
  4. Your reduced sized PDF file will be saved to your Desktop with a filename that starts with the name of your iStudio Publisher document file and ends with the filter name.

Here’s a screen shot showing the filters available to choose from in step 3 above:
PDF filters available from the PDF drop-down button in the print dialog

For more information about these PDF filters, click here to see an Apple Support Communities discussion topic about them.

Can I create large banners and posters using multiple sheets of paper?

Yes, you can use iStudio Publisher to create large posters and banners. iStudio Publisher incorporates the standard Mac OS X Page Setup dialog, which allows you to set any standard or custom page size. You can open the Page Setup dialog from the New Document dialog (click the Change button), the File menu, or the Page button in the Document Inspector.

Having completed your banner design, choose the menu option File > Export Document as PDF. You can then use a separate app to print the PDF on multiple sheets of paper.

We recommend using the free PosteRazor app for doing this. Note that PosteRazor cannot accept a PDF file as an input file and so you will need to open the PDF in Preview and export it as a different image format before inputting the image file into PosteRazor.

An alternative is the Tiler app, which offers the advantage of being able to accept a PDF file as an input.

Can I add a fancy frame or edge effect to my images?

We suggest using a separate app to add frames and edge effects to your images before bringing them into your iStudio Publisher documents, for example, ImageFramer (free version) or EasyFrame.

Can I print out multiple business cards or labels on Letter or A4 sized sheet stock?

Yes, you can print out multiple business cards or labels on Letter or A4 sized sheet stock.

To print out on plain card, which you will guillotine or cut yourself, simply miss out the layout template related instructions (steps 1, 2, 4 and 8) in the method described below.

Alternatively, if printing out on pre-cut cards/labels, which are typically supplied on Letter or A4 sized sheets, then some sheet stock suppliers will supply layout templates marked with the positions of the individual cut cards/labels on the larger sheet, to help with positioning. If your sheet stock supplier doesn’t have a PDF or Microsoft Word format layout template available for download from their website for the sheet stock, then in the method described below miss out steps 1, 2, 4 and 8, and instead position the cards/labels with the help of the rulers and snap grid.

iStudio Publisher can make use of the business card/label templates supplied by Avery in Microsoft Word format, as long as you are able to convert these to a PDF file for use in your iStudio Publisher document. TIP: If you have Mac OS X 10.7 Lion or later you can open a Word document in Preview and export it to PDF.

To print multiple business cards on Letter or A4 sized sheet stock:
  1. If using Avery (or similar) sheet stock, find and download the appropriate Avery template from the Avery website.
  2. If required, convert the Avery template to PDF, as described above.
  3. Set the paper size of your iStudio Publisher document to match the sheet stock size.
  4. If using a PDF template, insert/drag the template into your iStudio Publisher document and align it with the page. The template size will usually match the printer sheet stock size. TIP: It’s best to add a PDF template to the first master page so that it’s out of the way behind the business card/label content, which you should place on the first body page.
  5. Create one copy of your business card/label design.
  6. Select and group together all parts of your business card/label design, so that it can be selected and arranged as a single object.
  7. Make multiple copies of your business card/label design and manually arrange these on the page (within the alignment guides provided by the PDF template). TIP: To achieve finer positional control, you can apply small ‘nudge’ movements via the keyboard arrow keys to position a card/label design between the snap grid lines. You can also set a smaller grid spacing (settings available on the Document Inspector, on the Grid tab).
  8. If using a PDF template, delete it (or move it off the page on to the canvas area so that it’s handy for future reuse).
  9. Print. TIP: Print out a test copy on plain paper to check the card/label positioning before using your Avery sheet stock.
  10. If you ever need to update your card design, delete all but one copy, update it and then make fresh copies (repeat steps 5-9 above).
How can I convert images to CMYK?

You can convert an image to CMYK using a separate image processing application, for example, here’s how to use ColorSync Utility for this:

  1. Open the image in the Mac OS X ColorSync Utility (it’s located in the Utilites folder, which is itself in the Applications folder).
  2. Choose drop-down settings Apply Profile, and Output > Generic CMYK Profile, as shown in this example:
  3. Convert image to CMYK - apply Generic CMYK profile

  4. Click the Apply button.
  5. Choose drop-down settings Match to Profile, and Output > Generic CMYK Profile, as shown here:
  6. Convert image to CMYK - match to Generic CMYK profile

  7. Click the Apply button.
  8. Choose menu option File > Save As, set the new filename (and folder location, if required), and click the Save button to finish.

Problems you may encounter

Why are some characters displayed as a small rectangles?

iStudio Publisher is Unicode based and so all text code points should be recognized. Characters are displayed as small rectangles if they aren’t available in the selected font and will print or export as blanks. You will need to select a different font for these characters to display/print/export correctly.

When using the Character Viewer to insert special characters you can overcome this problem by opening the Collections drop-down and choosing the option “Containing selected character”. You can now simply select (or drag) a character/symbol in a particular font from the lower part of the Character Viewer into your document.

NOTE: Choose Edit > Special Characters to open the Character Viewer.

Why is iStudio Publisher running slowly?

iStudio Publisher doesn’t place a maximum size limit on the document files it will try to process because this capability will depend on your Mac’s hardware and on the other software you might have running. However, as an iStudio document file becomes very large (typically several hundred MB) your Mac will eventually reach the limits of its memory capacity and iStudio Publisher will start to run slowly and take longer to respond.

Freeing up some memory by closing other apps you aren’t using can help.

Running the Activity Monitor and selecting the System Memory tab will allow you to investigate how much memory and % CPU iStudio Publisher is taking and whether your Mac is experiencing page outs, which are all likely indicators of memory swapping slowness and of your Mac reaching its limits. For more information about using the Activity Monitor here’s an Apple support note.

Inserting a large number of high resolution images is the most common reason for an iStudio document becoming very large.

There are two different methods of reducing iStudio document file size, which you may want to use in combination when creating very large, image heavy documents.

Method 1 – Reduce image resolution before inserting images in an iStudio document

You will need to use a separate image editing app for this (Preview, for example).

To achieve good print quality, print shops typically require images with a minimum resolution of 300 DPI. However, if you insert a 300 DPI image into an iStudio Publisher document and then scale down its size, this increases its effective DPI because iStudio Publisher maintains the original image data and does not resample or compress it. With an image’s effective DPI now increased, you have the opportunity to reduce its resolution whilst still keeping it above the minimum 300 DPI required by the print shop. Doing this can produce significant reductions in document file size.

NOTE: For more information about DPI, please see iStudio Publisher’s Help page entitled “Image Inspector” (and especially the section entitled “Regarding DPI setting”).

After inserting images into an iStudio document and scaling them to the required size in your layout you can use the Image Inspector to check that each image has an effective DPI of at least 300. To do this, select an image, go to the Image Inspector, set the Use DPI adjustment to 300, and in the Fit section make sure that its Scale setting is at 100% or less. Repeat this for each image. Any images with a Scale setting of much less that 100% can be resized and resampled in the image editing app, so as to increase their Scale setting nearer to 100% when reinserted into the iStudio document.

Method 2 – Split up your document across several separate iStudio document files

To avoid having to pre-process images and reduce their file sizes prior to insertion in an iStudio document, you can keep down the iStudio document file size by arbitrarily splitting up your complete document across several separate iStudio document files, each containing a smaller number of images. This method requires a final step of assembling the complete document from all of the individual documents, which can done by exporting each of the iStudio documents to PDF file and then combining the PDFs.

When exporting a document to PDF file, iStudio does not compress image data. Whilst Method 2 may overcome the problem of iStudio Publisher running slowly it won’t reduce the size of the final PDF file. Instead, you can use these free filters to reduce PDF file size. It’s generally best to use the filters to reduce the size of each PDF file exported from iStudio Publisher, before then assembling these into the complete document.

Can I recover a huge document file that won’t open?

iStudio Publisher has an XML text based file structure, which can be processed at a terminal command line. With huge document files most of the size is generally due to the images, and you should be able to recover a huge document by removing some of the these images. If you recover your document in two or more part copies, with a different part range of the images in each copy, then overall you won’t lose any work.

As a first test, to confirm that your document will be recoverable, it’s best to try creating a new copy with all of the images removed. Here are some instructions for doing this for an example file called mydoc.ispx. Try repeating these steps with your document file, replacing the name mydoc.ispx with your filename (IMPORTANT: Your file name should not contain any space characters) or rename your file to mydoc.ispx.

  1. Open Terminal.app, which is in the /Applications/Utilities folder.
  2. Enter a cd command to change directory to the folder containing your iStudio Publisher document – in this example the document was on the Desktop:
    cd '/Users/andy/Desktop/'

    NOTE: Press the Return key to execute a command you have entered at the terminal prompt.

  3. Create a new copy of your file with all of the images removed, which you can do using the following command:
    awk '/<Image/&&n>=  0  {p=1;print}/<\/Image>/{p=0;++n}!p' mydoc.ispx > mydoc_NoImages.ispx

Here’s a screen shot of a terminal window session for the above example:
Terminal session example to remove all images

The outcome of completing these steps should be a new iStudio Publisher document called mydoc_NoImages.ispx on your Desktop. Try opening this file in iStudio Publisher to confirm that removing all of the images has fixed the problem of the file not opening. If it opens without error, here are some instructions for recovering a document in two parts, with a different range of the images in each copy. This example is for a file called mydoc.ispx. Try repeating these steps with your document file. You can skip steps 1 and 2 if you are following on from step 3 of the first example in the same terminal window.

  1. Open Terminal.app, which is in the /Applications/Utilities folder.
  2. Enter a cd command to change directory to the folder containing your iStudio Publisher document:
    cd '/Users/andy/Desktop/'
  3. Discover how many images your document contains (in this example it’s 28). At the terminal prompt enter:
    awk '/<Image/{p=1;print "Total images found… "n+1;++n}' mydoc.ispx
  4. These two command strings will each create a new copy of the document file with a different range of the images removed. You can change the values 14 and 15 to change the image range – we would suggest starting off by setting these values to about half the total number of images that you discover at step 3.
    Command string to keep images 1 to 14:
    awk '/<Image/&&n>=  14  {p=1;print}/<\/Image>/{p=0;++n}!p' mydoc.ispx > mydoc_Images1to14.ispx
    Command string to keep images 15 and above:
    awk '/<Image/&&n+1<  15  {p=1;print}/<\/Image>/{p=0;++n}!p' mydoc.ispx > mydoc_Images15to28.ispx

Here’s a screen shot of a terminal window session for the above example:
Terminal session example to remove different ranges of images

As a general approach for creating documents with very large file size, we would suggest using iStudio Publisher to create a number of ‘sub-documents’, export each of these to PDF file and then combine the PDFs as a final step.

Why are the Help pages out of date or not showing at all?

Help pages problems are caused by Mac OS X caching errors or corrupted cache files, and can be fixed by deleting the Help file caches, as follows:

Mac OS X Lion and Mountain Lion users only

If your computer is running Mac OS X 10.7 Lion or 10.8 Mountain Lion, you may need to complete the following steps a. to c. to make the Library folder visible in Finder:

  1. Navigate to the Utilities folder, which is located in the Applications folder.
  2. Open the Terminal application.
  3. Enter (or copy and paste) the following command into the terminal window and then press the Return key:
    chflags nohidden /Library
  4. Continue with steps 1. to 10.
All users
  1. Quit iStudio Publisher.
  2. Close the Help Viewer.
  3. In Finder, navigate to your user account Home folder, then to the Library folder, then to the Caches folder (~/Library/Caches).
  4. Search for all files in this folder with a file name that contains “help” and drag to Trash all files returned by the search. You can do the search by typing “help” in the Spotlight search field and setting the search bar options to “Caches” and File Name. Double check that you have the “Caches” option selected otherwise the search will also return files from other folders.
  5. Remaining in this folder, search for and Trash all files in this folder with a file name that contains “istudio”. When searching make sure you still have the search bar options “Caches” and File Name selected.
  6. In your user account Home folder, navigate to the Library folder, then to the Preferences folder (~/Library/Preferences).
  7. Search for and drag to Trash all files in this folder with a file name that contains “help”. When searching make sure you have the search bar options “Preferences” and File Name selected.
  8. Log out and log back in.
  9. Launch iStudio Publisher.
  10. Open the Help pages. On this first viewing, it may take several seconds before the Help pages display while the cache files are being rebuilt. Click on the Help links occasionally until the pages are displayed.
Notes
  • Cache files are temporary copies of files that Mac OS X creates automatically to provide faster access times. Sometimes these files can get out-of-date or corrupted. There is no danger in deleting cache files as Mac OS X will automatically recreate a fresh copy as required.
  • To check if the Help pages are out of date, choose menu option Help > Release Notes. The Help pages are updated with each new release of iStudio Publisher and details of the most recent release, including the version number, are shown at the top of the Release Notes page.
Why isn’t my iStudio Publisher document printing out correctly?

When printing, iStudio Publisher creates an internal PDF representation of the document, which it then sends to the printer.

To diagnose the cause of a print problem it’s useful to establish whether the problem is occurring at the PDF creation stage or at the printer. To test this, export your document to PDF file, which you can do by choosing menu option File > Export Document as PDF. Open the PDF file in Preview – if it looks correct iStudio Publisher is completing the PDF creation without error, and any differences between how the PDF looks in Preview and how your print out looks on paper will most probably be due to your printer settings.

To further diagnose a printer settings problem try printing the newly exported PDF file from Preview. Make sure that on the Print dialog the Auto Rotate checkbox is selected and (generally, unless you want to scale the size up or down) that the Scale is set to 100%.

Why can’t I save or print?

IMPORTANT: This FAQ only applies to the Website Download Edition of iStudio Publisher and not the App Store Edition.

This is because iStudio Publisher is running in unlicensed mode. Choose menu option Help > Licensing > Check License to confirm your license status. If unlicensed, you will need to register for a license – start by choosing menu option Help > Licensing > License.

If you have just registered iStudio Publisher, but the application is still running in unlicensed mode, there has been a problem with your registration, and you will need to repeat it.

IMPORTANT: If you are logged into your Mac as a Standard Account holder (as opposed to an Administrator Account holder) you will need to log in as an Admin when you register – click here for more information.

Why does iStudio Publisher stop working if I migrate my applications?

IMPORTANT: This FAQ only applies to the Website Download Edition of iStudio Publisher and not the App Store Edition.

Each iStudio Publisher license will only work on the particular Mac on which it was originally installed. If you migrate your applications to a new Mac, you will need to reinstall your license by completing the following two steps:

  1. Deactivate the license on your old Mac (by choosing menu option Help > Licensing > Unlicense). You will be reminded of your License Activation Code and so won’t need to find your original purchase receipt email.
  2. License your new Mac as normal.

If you don’t reinstall your license you will receive the following message: “Your license is invalid on this computer. Is this the computer that you licensed for iStudio Publisher? If you have migrated your account (and license) to this computer from another computer you will need to Unlicense iStudio Publisher on the other computer and then License this one.”

If you are unable to deactivate the license on your old Mac, for example, if the hard drive has crashed, please proceed as follows:

  1. Contact us for a license reset. To help us identify you, please tell us your License Activation Code or the email address you used to make your purchase.
  2. We will email you to confirm your license has been reset.
  3. Run iStudio Publisher.
  4. Choose menu option Help > Licensing > License, and install you license. There are short video tutorials showing how to download and install iStudio Publisher, and install your full license.
What should I do if my Mac’s hard drive crashes?
App Store Edition

Reinstall iStudio Publisher by following these steps:

  1. Sign in to the App Store app (using the same iTunes account login details that you used to make your purchase of iStudio Publisher).
  2. Go to your App Store Purchased items by choosing menu option Store > Purchased.
  3. Click the Install button to install iStudio Publisher.
Website Download Edition

Reinstall and relicense iStudio Publisher by following these steps:

  1. Download iStudio Publisher from our downloads page.
  2. Install iStudio Publisher from the download file.
  3. Choose menu option Help > Licensing > Licensing Special > Relicense to reinstall an existing license. You can Relicense without having to refer back to your original purchase receipt email to find your License Activation Code.
Where is iStudio Publisher in my file system?

Follow these steps to locate all existing copies of iStudio Publisher on your Mac:

  1. Open Terminal.app, which is in the /Applications/Utilities folder.
  2. Enter (or copy and paste) the following command into the terminal window and then press the Return key to execute it:
    mdfind kMDItemContentType="com.apple.application-bundle" | grep iStudio

Here’s a screen shot showing the terminal window at step 2, just before executing the command:
Terminal session to search for iStudio Publisher

The command will report the pathlist of each copy of iStudio Publisher that’s present on your Mac.

Why can’t I install or open my App Store Edition of iStudio Publisher?

IMPORTANT: This FAQ only applies to the App Store Edition of iStudio Publisher and not the Website Download Edition.

If you encounter an error when trying to install or open iStudio Publisher you can delete and reinstall iStudio Publisher by following these steps:

  1. Locate and delete all existing App Store copies of iStudio Publisher by following these steps:
    1. Open Terminal.app, which is in the /Applications/Utilities folder.
    2. Enter (or copy and paste) the following command into the terminal window and then press the Return key to execute it:
      mdfind kMDItemAppStoreHasReceipt=1 | grep iStudio
    3. The command will report the pathlist of each existing App Store copy of iStudio Publisher. Locate and delete each of these copies.
  2. Empty your Trash – this is important!
  3. Sign in to the App Store app (using the same iTunes account login details that you used to make your purchase of iStudio Publisher).
  4. Go to your App Store Purchased items by choosing menu option Store > Purchases.
  5. Click the Install button to install iStudio Publisher.

Here’s a screen shot showing the terminal window at step 1b, just before executing the command:
Terminal session to search for App Store copies of iStudio Publisher

IMPORTANT: Unless you have deleted all existing App Store copies of iStudio Publisher and emptied your Trash your App Store Purchased items may continue to show iStudio Publisher as “Installed” instead of giving you an active “Install” button.

Didn’t find an answer to your question? Here are some other places to look…

Video Tutorials

Don’t know where to start? Our video tutorials will get you up to speed quickly.

Help Pages

The Help pages provide details about using all of the controls and settings.

Contact Support

Contact support for help, and with bugs, requests, comments and ideas.